
<!DOCTYPE html>
<html lang="en">
<head><meta charset="utf-8" /><meta http-equiv="X-UA-Compatible" content="IE=edge" /><meta name="viewport" content="width=device-width, initial-scale=1" /><title>
	Ypsi-based credit repair company launches financial literacy academy for youth
</title><link rel="alternate" type="application/rss+xml" title="Subscribe to the Concentrate RSS feed!" href="https://feeds.feedburner.com/concentratemedia" />
<link rel="shortcut icon" href="/images/favicon.ico" />
<link rel="icon" type="image/png" href="/images/favicon.png" />
<link rel="canonical" href="https://www.secondwavemedia.com/concentrate/features/bcicacademy0624.aspx" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.secondwavemedia.com/concentrate/features/bcicacademy0624.aspx" />
<meta property="og:site_name" content="Concentrate" />
<meta property="og:title" content="Ypsi-based credit repair company launches financial literacy academy for youth" />
<meta property="og:image" content="https://www.secondwavemedia.com/concentrate/images/Features/Issue_624/willie-johnson-lynwood-powell-01-1600.jpg" />
<meta property="og:image:width" content="1600" />
<meta property="og:image:height" content="1065" />
<meta property="og:description" content="Ypsilanti residents and entrepreneurs Willie Johnson and Lynwood Powell want to help young people avoid some of the financial pitfalls they experienced as young adults." />
<meta property="fb:admins" content="1054316675" />
<meta property="fb:admins" content="674682725" />
<meta property="fb:admins" content="1212364057" />
<meta property="fb:app_id" content="263274063696517" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@concentratea2" />
<meta name="twitter:title" content="Ypsi-based credit repair company launches financial literacy academy for youth" />
<meta name="twitter:url" content="https://www.secondwavemedia.com/concentrate/features/bcicacademy0624.aspx" />
<meta name="twitter:image" content="https://www.secondwavemedia.com/concentrate/images/Features/Issue_624/willie-johnson-lynwood-powell-01-1600.jpg" />
<link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/twitter-bootstrap/3.3.5/css/bootstrap.min.css">
<link rel="stylesheet" href="https://unpkg.com/flickity@2.2.1/dist/flickity.min.css">
<link rel="stylesheet" href="https://unpkg.com/flickity-fullscreen@1.1.1/fullscreen.css">
<link rel="stylesheet" type="text/css" href="/css/combined.min.css?v=637759407073396143" />
<link rel="stylesheet" type="text/css" href="/css/site.css?v=637787277093535195" />
<script type="text/javascript" src="/script/combined.min.js?v=637456080900000000"></script>
<script src="https://cdnjs.cloudflare.com/ajax/libs/twitter-bootstrap/3.3.5/js/bootstrap.min.js"></script>
<script type="text/javascript">OA_zones = {'Flex1125 0':9169,'Footer 01':1701,'Footer 02':1702,'Footer 03':1703,'Footer 04':1704,'Footer 05':1705,'Footer 06':1706,'Footer 07':1707,'Footer 08':1708,'Footer 09':1709,'Footer 10':1710,'Footer 11':1711,'Footer 12':1712,'Leaderboard 0':9170,'Sponsor: Network':9171};
</script>
<script type='text/javascript' src='https://dsx.issuemediagroup.com/www/delivery/spcjs.php?Page=17~%2ffeatures%2fbcicacademy0624.aspx&amp;Tag=17%7eEducation%2c17%7eKids+and+Education%2c17%7eEntrepreneurship%2c17%7eBusiness%2c17%7eFinance%2c17%7eBusiness+Development%2c17%7eOn+the+Ground%2c17%7e90143965-fbb0-416e-99c1-0d9d9b6d89ea%2c17%7eadf53f38-0853-4720-8d1e-b83c46f811bd%2c17%7e3dbf1eb1-ef0f-4e02-b246-05e4b88a2d05%2c17%7eb1e096bb-097d-4688-94ed-279a7fb76c11'></script>
<meta name="description" content="Ypsilanti residents and entrepreneurs Willie Johnson and Lynwood Powell want to help young people avoid some of the financial pitfalls they experienced as young adults." />
<meta name="keywords" content="Ypsilanti, Ypsi, Bad Credit is Childish, BCIC Academy, Time Travel Credit Repair, credit repair, financial literacy, financial literacy for kids, Michael Vick, Willie Johnson, Lynwood Powell" />
<script>(function (p, i, c, o) { var n = new Event("pico-init"); i[p] = i[p] || function () { (i[p].queue = i[p].queue || []).push(arguments) }, i.document.addEventListener("pico-init", function (e) { var t = i.Pico.getInstance(e, { publisherId: o, picoInit: n }, i); t.handleQueueItems(i[p].queue), i[p] = function () { return t.handleQueueItems([arguments]) } }, !1); var e = i.document.createElement("script"), t = i.document.getElementsByTagName("script")[0]; e.async = 1, e.src = c, e.onload = function (e) { return i.Pico.getInstance(e, { publisherId: o, picoInit: n }, i) }, t.parentNode.insertBefore(e, t) })("pico", window, "https://gadget.pico.tools/wrapper.min.js", "d5a634fa-8a08-4893-b22c-0c62f653ad60");</script>
<script>
var isRootSite = false;
</script>
<script type="text/javascript">
var google_domain = 'www.concentratemedia.com';
var google_cx = '006919356486600035371:af5wbwpwbzs';
var google_cof = 'FORID:11';
var site_base_url = '/concentrate';

(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','//www.google-analytics.com/analytics.js','ga');

ga('create','UA-57673722-5','auto');
ga('create', 'UA-1219467-8', 'auto', 'subsite');

ga('send', 'pageview');
ga('subsite.send', 'pageview', '/features/bcicacademy0624.aspx');

$(function () {
// ref:http://www.axllent.org/docs/programming-tips/google-analytics/
    $(document).find('body').click(
        function _gaLt(event) {
            var el = event.srcElement || event.target;
            while (el && (typeof el.tagName == 'undefined' || el.tagName.toLowerCase() != 'a' || !el.href))
                el = el.parentNode;
            if (el && el.href && el.href.indexOf(location.host) == -1) {
                // for universal analytics, swap line below for _gaq.push line
                ga("send", "event", "Outbound Link", el.href, document.location.pathname + document.location.search);
                ga("subsite.send", "event", "Outbound Link", el.href, 'http://www.secondwavemedia.com/concentrate/features/bcicacademy0624.aspx');
                //_gaq.push(["_trackEvent", "Outbound Link", el.href, document.location.pathname + document.location.search]);
                /* if target not set then delay opening of window by 0.5s to allow tracking */
                if (!el.target || el.target.match(/^_(self|parent|top)$/i)) {
                    setTimeout(function () {
                        document.location.href = el.href;
                    }.bind(el), 500);
                    event.preventDefault ? event.preventDefault() : event.returnValue = !1;
                }
            }
        }
    );
})
</script>

<!--[if lt IE 9]>
<script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.min.js"></script>
<script src="https://cdnjs.cloudflare.com/ajax/libs/respond.js/1.4.2/respond.min.js"></script>
<![endif]-->
</head>
<body class="concentrate ch-long-featured-story FeaturedStoryLong has-treatment treatment-on-the-ground">
<div id="fb-root"></div>
<script type="text/javascript">
var facebookAppId = '263274063696517';
</script>
<form method="post" action="./bcicacademy0624.aspx" id="aspnetForm">
<div>
<input type="hidden" name="__VIEWSTATE" id="__VIEWSTATE" value="KxI9u88J+5/j3VHnAfPCxGtHVMB5+hgdf6NqpUWQall4kCv7rsztmQnBGxwfKW/Xw/nwwe1HIc3XVDS/P9eQRsUuhXc=" />
</div>
<div class="container-fluid page-container ">
<div class="container-fluid headerSection no-padding">
<div class="container-fluid container-inner no-padding">
<div class="header">
<nav class="top-nav navbar navbar-inverse navbar-fixed-top">
<div class="container">
<div class="navbar-header">
<div class="navbar-header-wrapper">
<ul class="nav navbar-nav region-nav">
<li class="dropdown">
<a href="#" class="dropdown-toggle" data-toggle="dropdown" role="button" aria-haspopup="true" aria-expanded="false">Region <span class="caret"></span></a>
<ul class="dropdown-menu"><li><a href='/'>Second Wave - Michigan</a></li><li><a href='/capitalgains/'>Capital Gains - Lansing</a></li><li><a href='/midland/'>Catalyst Midland</a></li><li><a href='/concentrate/'>Concentrate - Ann Arbor/Ypsi</a></li><li><a href='/epicenter/'>Epicenter - Mount Pleasant</a></li><li><a href='/baycity/'>Route Bay City</a></li><li><a href='/southwest-michigan/'>Southwest Michigan</a></li><li><a href='/upper-peninsula/'>Upper Peninsula</a></li><li><a href='/the-keel/'>The Keel - Port Huron</a></li><li><a href='/lakeshore/'>The Lakeshore</a></li><li><a href='/metromode/'>Metromode - Metro Detroit</a></li>
<li><a href='http://www.flintside.com/' target="_blank">Flintside - Flint</a></li>
<li><a href='http://www.modeldmedia.com/' target="_blank">Model D - Detroit</a></li>
<li><a href='http://www.rapidgrowthmedia.com/' target="_blank">Rapid Growth - Grand Rapids</a></li>
</ul>
</li>
</ul>
<ul class="nav navbar-nav focus-nav hidden-xs">
<li class="dropdown">
<a href="#" class="dropdown-toggle" data-toggle="dropdown" role="button" aria-haspopup="true" aria-expanded="false">Focus Areas<span class="caret"></span></a>
<ul class="dropdown-menu"><li><a href='/concentrate/focus/art-and-culture.aspx'>Arts and Culture</a></li><li><a href='/concentrate/focus/community-development.aspx'>Community Development</a></li><li><a href='/concentrate/focus/diversity.aspx'>Diversity</a></li><li><a href='/concentrate/focus/economic-development.aspx'>Economic Development</a></li><li><a href='/concentrate/focus/entrepreneurship.aspx'>Entrepreneurship</a></li><li><a href='/concentrate/focus/equity.aspx'>Equity</a></li><li><a href='/concentrate/focus/healthy-communities.aspx'>Healthy Communities</a></li><li><a href='/concentrate/focus/kids-and-education.aspx'>Kids and Education</a></li><li><a href='/concentrate/focus/sustainability.aspx'>Sustainability</a></li><li><a href='/concentrate/focus/technology-and-innovation.aspx'>Technology and Innovation</a></li><li><a href='/concentrate/focus/transportation.aspx'>Transportation</a></li></ul>
</li>
</ul>
<ul class="nav navbar-nav subregion-nav hidden-xs">
<li class="dropdown">
<a href="#" class="dropdown-toggle" data-toggle="dropdown" role="button" aria-haspopup="true" aria-expanded="false">City<span class="caret"></span></a>
<ul class="dropdown-menu"><li><a href='/concentrate/cities/AnnArbor/default.aspx'>Ann Arbor</a></li><li><a href='/concentrate/cities/chelsea/default.aspx'>Chelsea</a></li><li><a href='/concentrate/cities/dexter/default.aspx'>Dexter</a></li><li><a href='/concentrate/cities/milan/default.aspx'>Milan</a></li><li><a href='/concentrate/cities/saline/default.aspx'>Saline</a></li><li><a href='/concentrate/cities/Ypsilanti/default.aspx'>Ypsilanti</a></li></ul>
</li>
</ul>
<ul class="nav navbar-nav series-nav hidden-xs">
<li class="dropdown">
<a href="#" class="dropdown-toggle" data-toggle="dropdown" role="button" aria-haspopup="true" aria-expanded="false">Series<span class="caret"></span></a>
<ul class="dropdown-menu multi-column columns-2"><div class="row"><div class="col-sm-6"><ul class="multi-column-dropdown"><li class="dropdown-header">Concentrate</li>
<li><a href='/concentrate/series/detroit-driven.aspx'>Detroit Driven</a></li><li><a href='/concentrate/series/inside-our-outdoors.aspx'>Inside our Outdoors</a></li><li><a href='/concentrate/series/on-the-ground.aspx'>On The Ground</a></li>
</ul></div><div class="col-sm-6"><ul class="multi-column-dropdown"><li class="dropdown-header">Statewide</li><li><a href='/series/areas-of-concern.aspx'>Areas of Concern</a></li><li><a href='/series/bridging-the-talent-gap.aspx'>Bridging the Talent Gap</a></li><li><a href='/series/covid19.aspx'>COVID19</a></li><li><a href='/series/cyber-security.aspx'>Cyber Security</a></li><li><a href='/series/exploring-economic-equity.aspx'>Exploring Economic Equity</a></li><li><a href='/series/forestry.aspx'>Forestry</a></li><li><a href='/series/girl-scouts-se-michigan-team-up.aspx'>Girl Scouts SE Michigan Team Up</a></li><li><a href='/series/good-food.aspx'>Good Food</a></li><li><a href='/series/greater-lakes.aspx'>Greater Lakes</a></li><li><a href='/series/inside-our-outdoors.aspx'>Inside our Outdoors</a></li><li><a href='/series/invasive-species.aspx'>Invasive Species</a></li><li><a href='/series/michigan-nightlight.aspx'>Michigan Nightlight</a></li><li><a href='/series/michigan-agricultural-future.aspx'>Michigan's Agricultural Future</a></li><li><a href='/series/state-of-health-podcast.aspx'>Michigan's State of Health Podcast</a></li><li><a href='/series/nonprofit-journal-project.aspx'>Nonprofit Journal Project</a></li><li><a href='/series/preserving-michigan.aspx'>Preserving Michigan</a></li><li><a href='/series/state-of-health.aspx'>State of Health</a></li><li><a href='/series/stories-of-change.aspx'>Stories of Change</a></li><li><a href='/series/voices-of-youth.aspx'>Voices of Youth</a></li>
</ul></div></div></ul>
</li>
</ul>
<ul id="navbar-social" class="nav navbar-nav hidden-sm hidden-md hidden-lg">
<li>
<a href="https://www.facebook.com/pages/Concentrate/234652603224031" target="_blank" title=""><img src="/images/facebook_on.png" alt="Facebook" /></a>
<a href="https://twitter.com/concentratea2" target="_blank"><img src="/images/twitter_on.png" alt="Twitter" /></a>
<a type="application/rss+xml" rel="alternate" title="Subscribe to the Concentrate RSS feed!" target="_blank" href="https://feeds.feedburner.com/concentratemedia"><img src="/images/rss_on.png" alt="RSS Feed" /></a>
<a class="search" href="#" onclick="$('.searchContainer').fadeToggle(); $('#q').focus(); return false;"><img src="/images/icon_search.png" /></a>
<div class="searchContainer"><input class="searchBox" id="q" name="q" type="text" onkeydown="return SubmitOnEnter(this,event,'');" /></div>
</li>
</ul>
</div>
<button type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target=".navbar-mobile" aria-expanded="false" aria-controls="navbar-top">
<span class="sr-only">Toggle navigation</span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
</button>
<div class="navbar-logo"><a href="/concentrate/"><img class="image-logo" src="/images/logo-concentrate.png" alt="Concentrate" /></a></div>
</div>
<div class="nav navbar-nav navbar-mobile collapse navbar-collapse">
<ul class="nav navbar-nav focus-nav visible-xs">
<li class="dropdown">
<a href="#" class="dropdown-toggle" data-toggle="dropdown" role="button" aria-haspopup="true" aria-expanded="false">Focus Areas<span class="caret"></span></a>
<ul class="dropdown-menu"><li><a href='/concentrate/focus/art-and-culture.aspx'>Arts and Culture</a></li><li><a href='/concentrate/focus/community-development.aspx'>Community Development</a></li><li><a href='/concentrate/focus/diversity.aspx'>Diversity</a></li><li><a href='/concentrate/focus/economic-development.aspx'>Economic Development</a></li><li><a href='/concentrate/focus/entrepreneurship.aspx'>Entrepreneurship</a></li><li><a href='/concentrate/focus/equity.aspx'>Equity</a></li><li><a href='/concentrate/focus/healthy-communities.aspx'>Healthy Communities</a></li><li><a href='/concentrate/focus/kids-and-education.aspx'>Kids and Education</a></li><li><a href='/concentrate/focus/sustainability.aspx'>Sustainability</a></li><li><a href='/concentrate/focus/technology-and-innovation.aspx'>Technology and Innovation</a></li><li><a href='/concentrate/focus/transportation.aspx'>Transportation</a></li></ul>
</li>
</ul>
<ul class="nav navbar-nav subregion-nav visible-xs">
<li class="dropdown">
<a href="#" class="dropdown-toggle" data-toggle="dropdown" role="button" aria-haspopup="true" aria-expanded="false">City<span class="caret"></span></a>
<ul class="dropdown-menu"><li><a href='/concentrate/cities/AnnArbor/default.aspx'>Ann Arbor</a></li><li><a href='/concentrate/cities/chelsea/default.aspx'>Chelsea</a></li><li><a href='/concentrate/cities/dexter/default.aspx'>Dexter</a></li><li><a href='/concentrate/cities/milan/default.aspx'>Milan</a></li><li><a href='/concentrate/cities/saline/default.aspx'>Saline</a></li><li><a href='/concentrate/cities/Ypsilanti/default.aspx'>Ypsilanti</a></li></ul>
</li>
</ul>
<ul class="nav navbar-nav series-nav visible-xs">
<li class="dropdown">
<a href="#" class="dropdown-toggle" data-toggle="dropdown" role="button" aria-haspopup="true" aria-expanded="false">Series<span class="caret"></span></a>
<ul class="dropdown-menu multi-column columns-2"><div class="row"><div class="col-sm-6"><ul class="multi-column-dropdown"><li class="dropdown-header">Concentrate</li>
<li><a href='/concentrate/series/detroit-driven.aspx'>Detroit Driven</a></li><li><a href='/concentrate/series/inside-our-outdoors.aspx'>Inside our Outdoors</a></li><li><a href='/concentrate/series/on-the-ground.aspx'>On The Ground</a></li>
</ul></div><div class="col-sm-6"><ul class="multi-column-dropdown"><li class="dropdown-header">Statewide</li><li><a href='/series/areas-of-concern.aspx'>Areas of Concern</a></li><li><a href='/series/bridging-the-talent-gap.aspx'>Bridging the Talent Gap</a></li><li><a href='/series/covid19.aspx'>COVID19</a></li><li><a href='/series/cyber-security.aspx'>Cyber Security</a></li><li><a href='/series/exploring-economic-equity.aspx'>Exploring Economic Equity</a></li><li><a href='/series/forestry.aspx'>Forestry</a></li><li><a href='/series/girl-scouts-se-michigan-team-up.aspx'>Girl Scouts SE Michigan Team Up</a></li><li><a href='/series/good-food.aspx'>Good Food</a></li><li><a href='/series/greater-lakes.aspx'>Greater Lakes</a></li><li><a href='/series/inside-our-outdoors.aspx'>Inside our Outdoors</a></li><li><a href='/series/invasive-species.aspx'>Invasive Species</a></li><li><a href='/series/michigan-nightlight.aspx'>Michigan Nightlight</a></li><li><a href='/series/michigan-agricultural-future.aspx'>Michigan's Agricultural Future</a></li><li><a href='/series/state-of-health-podcast.aspx'>Michigan's State of Health Podcast</a></li><li><a href='/series/nonprofit-journal-project.aspx'>Nonprofit Journal Project</a></li><li><a href='/series/preserving-michigan.aspx'>Preserving Michigan</a></li><li><a href='/series/state-of-health.aspx'>State of Health</a></li><li><a href='/series/stories-of-change.aspx'>Stories of Change</a></li><li><a href='/series/voices-of-youth.aspx'>Voices of Youth</a></li>
</ul></div></div></ul>
</li>
</ul>
</div>
<div id="navbar-secondary" class="collapse navbar-collapse navbar-mobile">
<ul class="nav navbar-nav navbar-general">
<li class="active"><a href="/concentrate/about/about.aspx" class="nav-about">About</a></li>
<li><a href="/concentrate/about/contactus.aspx" class="nav-contact">Contact</a></li>
</ul>
<ul id="navbar-social" class="nav navbar-nav hidden-xs">
<li>
<a href="https://www.facebook.com/pages/Concentrate/234652603224031" target="_blank" title=""><img src="/images/facebook_on.png" alt="Facebook" /></a>
<a href="https://twitter.com/concentratea2" target="_blank"><img src="/images/twitter_on.png" alt="Twitter" /></a>
<a type="application/rss+xml" rel="alternate" title="Subscribe to the Concentrate RSS feed!" target="_blank" href="https://feeds.feedburner.com/concentratemedia"><img src="/images/rss_on.png" alt="RSS Feed" /></a>
<a class="search" href="#" onclick="$('.searchContainer').fadeToggle(); $('#q').focus(); return false;"><img src="/images/icon_search.png" /></a>
<div class="searchContainer"><input class="searchBox" id="q" name="q" type="text" onkeydown="return SubmitOnEnter(this,event,'');" /></div>
</li>
</ul>
</div>
</div>
</nav>
</div>
</div>
</div>
<div class="container-fluid mastheadSection no-padding">
<div class="container-fluid container-inner no-padding">
<div id="ctl00_PageHeader_Masthead_MastheadGallery" class="mediaGallery mode-lazy aspect-3x1">
<div class="carousel carousel-main" data-flickity='{ "cellAlign":"left", "contain": true, "wrapAround": true, "autoPlay": false, "pauseAutoPlayOnHover": true, "fullscreen": false, "fade": true, "adaptiveHeight": true, "imagesLoaded": true, "lazyLoad":true, "cellSelector": ".carousel-cell", "setGallerySize": true, "prevNextButtons": false, "pageDots": false }'>
<div class="carousel-cell">
<div class=" cell-item">
<div class="carousel-image-container">
<img class="carousel-image " alt="Bad Credit is Childish co-owners Willie Johnson and Lynwood Powell." sizes="(min-width:1200px) 1600px, (min-width:1080px) 1125px, (min-width:850px) 980px, (min-width:571px) 750px, (min-width:400px) 500px, (min-width:200px) 265px, 265px" data-flickity-lazyload-srcset="/concentrate/images/Features/Issue_624/willie-johnson-lynwood-powell-mast-01.jpg?s=t 120w, /concentrate/images/Features/Issue_624/willie-johnson-lynwood-powell-mast-01.jpg?s=l 265w, /concentrate/images/Features/Issue_624/willie-johnson-lynwood-powell-mast-01.jpg?s=lf 500w, /concentrate/images/Features/Issue_624/willie-johnson-lynwood-powell-mast-01.jpg?s=f 750w, /concentrate/images/Features/Issue_624/willie-johnson-lynwood-powell-mast-01.jpg?s=m 980w, /concentrate/images/Features/Issue_624/willie-johnson-lynwood-powell-mast-01.jpg?s=p 1125w, /concentrate/images/Features/Issue_624/willie-johnson-lynwood-powell-mast-01.jpg?s=mx 1600w" data-flickity-lazyload-src="/concentrate/images/Features/Issue_624/willie-johnson-lynwood-powell-mast-01.jpg" />
<noscript>
 <img class="carousel-image "
      alt="Bad Credit is Childish co-owners Willie Johnson and Lynwood Powell."
      sizes="(min-width:1200px) 1600px, (min-width:1080px) 1125px, (min-width:850px) 980px, (min-width:571px) 750px, (min-width:400px) 500px, (min-width:200px) 265px, 265px"
      srcset="/concentrate/images/Features/Issue_624/willie-johnson-lynwood-powell-mast-01.jpg?s=t 120w, /concentrate/images/Features/Issue_624/willie-johnson-lynwood-powell-mast-01.jpg?s=l 265w, /concentrate/images/Features/Issue_624/willie-johnson-lynwood-powell-mast-01.jpg?s=lf 500w, /concentrate/images/Features/Issue_624/willie-johnson-lynwood-powell-mast-01.jpg?s=f 750w, /concentrate/images/Features/Issue_624/willie-johnson-lynwood-powell-mast-01.jpg?s=m 980w, /concentrate/images/Features/Issue_624/willie-johnson-lynwood-powell-mast-01.jpg?s=p 1125w, /concentrate/images/Features/Issue_624/willie-johnson-lynwood-powell-mast-01.jpg?s=mx 1600w"
      src="/concentrate/images/Features/Issue_624/willie-johnson-lynwood-powell-mast-01.jpg"
     />
 </noscript>
</div>
<div class="captionOverlay"><div class="captionText">Bad Credit is Childish co-owners Willie Johnson and Lynwood Powell. <span class='image-credits'>Doug Coombe</span></div></div>
</div>
</div>
</div>
<div class="clear"></div>
</div>
</div>
</div>
<div class="container-fluid contentSection no-padding">
<div class="container-fluid container-inner no-padding">
<div class="container">
<div class="row">
<div class="col-md-12 page-heading clearfix ">
<h1 class="treatment-heading site-concentrate page-title"><span class="title ">Ypsilanti</span></h1>
<h1 class="page-title page-title-has-heading">Ypsi-based credit repair company launches financial literacy academy for youth</h1>
<div class="byline" style='x'>
<span class="author">Sarah Rigg</span> |
<span class="date">Wednesday, January 26, 2022</span>
</div>
<div class='content-block heading-text'>
Ypsilanti residents and entrepreneurs Willie Johnson and Lynwood Powell want to help young people avoid some of the financial pitfalls they experienced as young adults.
</div>
<div class="contentMeta">
<div class="share">
<span class="shareText">Share</span>
<span class="buttons">
<a class="shareFacebook" target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3a%2f%2fwww.secondwavemedia.com%2fconcentrate%2ffeatures%2fbcicacademy0624.aspx" onclick="ga('send','social','facebook','send','/concentrate/features/bcicacademy0624.aspx');ga('subsite.send','social','facebook','send','/features/bcicacademy0624.aspx');"><img src="/images/share_facebook.png" alt="Share on Facebook" /></a>
<a class="shareTwitter" target="_blank" href="https://twitter.com/share?url=https%3a%2f%2fwww.secondwavemedia.com%2fconcentrate%2ffeatures%2fbcicacademy0624.aspx&amp;text=Ypsi-based+credit+repair+company+launches+financial+literacy+academy+for+youth" onclick="ga('send','social','twitter','send','/concentrate/features/bcicacademy0624.aspx');ga('subsite.send','social','twitter','send','/features/bcicacademy0624.aspx');"><img src="/images/share_twitter.png" alt="Share on Twitter" /></a>
<a class="shareLinkedin" target="_blank" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https%3a%2f%2fwww.secondwavemedia.com%2fconcentrate%2ffeatures%2fbcicacademy0624.aspx&amp;title=Ypsi-based+credit+repair+company+launches+financial+literacy+academy+for+youth" onclick="ga('send','social','linkedin','send','/concentrate/features/bcicacademy0624.aspx');ga('subsite.send','social','linkedin','send','/features/bcicacademy0624.aspx');"><img src="/images/share_linkedin.png" alt="Share on LinkedIn" /></a>
<a class="shareMailto" href="mailto:?Body=https%3a%2f%2fwww.secondwavemedia.com%2fconcentrate%2ffeatures%2fbcicacademy0624.aspx&amp;Subject=Share:Ypsi-based+credit+repair+company+launches+financial+literacy+academy+for+youth" onclick="ga('send','social','email','send','/concentrate/features/bcicacademy0624.aspx');ga('subsite.send','social','email','send','/features/bcicacademy0624.aspx');"><img src="/images/share_email.png" alt="Share through Email" /></a></span>
<script>
        </script>
</div>
</div>
</div>
</div>
<div class="row">
<div class="col-xs-12 col-md-2 hidden-xs hidden-sm"></div>
<div class="col-xs-12 col-md-8">
<div class="leaderboard full-width">

<div class="adzone " id="ctl00_ContentPlaceHolder1_ctl02">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Flex1125 0');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=e66444875292492485fece742d0abeab&amp;cb=69626319719' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=17&amp;zoneid=9169&amp;cb=69626319719&amp;n=e66444875292492485fece742d0abeab&amp;Page=17~%2fconcentrate%2ffeatures%2fbcicacademy0624.aspx&amp;Tag=17%7eEducation%2c17%7eKids+and+Education%2c17%7eEntrepreneurship%2c17%7eBusiness%2c17%7eFinance%2c17%7eBusiness+Development%2c17%7eOn+the+Ground%2c17%7e90143965-fbb0-416e-99c1-0d9d9b6d89ea%2c17%7eadf53f38-0853-4720-8d1e-b83c46f811bd%2c17%7e3dbf1eb1-ef0f-4e02-b246-05e4b88a2d05%2c17%7eb1e096bb-097d-4688-94ed-279a7fb76c11' border='0' alt='' /></a></noscript>
</div>
</div>
<div class="leaderboard">

<div class="adzone " id="ctl00_ContentPlaceHolder1_ctl03">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Leaderboard 0');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=8b5d59d7225f445b8146d2f626b9ef39&amp;cb=69626319719' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=17&amp;zoneid=9170&amp;cb=69626319719&amp;n=8b5d59d7225f445b8146d2f626b9ef39&amp;Page=17~%2fconcentrate%2ffeatures%2fbcicacademy0624.aspx&amp;Tag=17%7eEducation%2c17%7eKids+and+Education%2c17%7eEntrepreneurship%2c17%7eBusiness%2c17%7eFinance%2c17%7eBusiness+Development%2c17%7eOn+the+Ground%2c17%7e90143965-fbb0-416e-99c1-0d9d9b6d89ea%2c17%7eadf53f38-0853-4720-8d1e-b83c46f811bd%2c17%7e3dbf1eb1-ef0f-4e02-b246-05e4b88a2d05%2c17%7eb1e096bb-097d-4688-94ed-279a7fb76c11' border='0' alt='' /></a></noscript>
</div>
</div>
<div id="main-content" class='content-block treatment-on-the-ground'>
<div class="featuredImage">
<div class="overlay"></div>
<div id="ctl00_ContentPlaceHolder1_ctl05" class="mediaGallery caption-below mode-lazy featured-media-gallery">
<div class="carousel carousel-main" data-flickity='{ "cellAlign":"left", "contain": true, "wrapAround": true, "autoPlay": false, "pauseAutoPlayOnHover": true, "fullscreen": true, "fade": true, "adaptiveHeight": true, "imagesLoaded": true, "lazyLoad":true, "cellSelector": ".carousel-cell", "setGallerySize": true, "prevNextButtons": true, "pageDots": false }'>
<div class="carousel-cell">
<div class=" cell-item">
<div class="carousel-image-container">
<img class="carousel-image " alt="Bad Credit is Childish co-owners Willie Johnson and Lynwood Powell." sizes="(min-width:1200px) 1600px, (min-width:1080px) 1125px, (min-width:850px) 980px, (min-width:571px) 750px, (min-width:400px) 500px, (min-width:200px) 265px, 265px" data-flickity-lazyload-srcset="/concentrate/images/Features/Issue_624/willie-johnson-lynwood-powell-01-1600.jpg?s=t 120w, /concentrate/images/Features/Issue_624/willie-johnson-lynwood-powell-01-1600.jpg?s=l 265w, /concentrate/images/Features/Issue_624/willie-johnson-lynwood-powell-01-1600.jpg?s=lf 500w, /concentrate/images/Features/Issue_624/willie-johnson-lynwood-powell-01-1600.jpg?s=f 750w, /concentrate/images/Features/Issue_624/willie-johnson-lynwood-powell-01-1600.jpg?s=m 980w, /concentrate/images/Features/Issue_624/willie-johnson-lynwood-powell-01-1600.jpg?s=p 1125w, /concentrate/images/Features/Issue_624/willie-johnson-lynwood-powell-01-1600.jpg?s=mx 1600w" data-flickity-lazyload-src="/concentrate/images/Features/Issue_624/willie-johnson-lynwood-powell-01-1600.jpg" />
<noscript>
 <img class="carousel-image "
      alt="Bad Credit is Childish co-owners Willie Johnson and Lynwood Powell."
      sizes="(min-width:1200px) 1600px, (min-width:1080px) 1125px, (min-width:850px) 980px, (min-width:571px) 750px, (min-width:400px) 500px, (min-width:200px) 265px, 265px"
      srcset="/concentrate/images/Features/Issue_624/willie-johnson-lynwood-powell-01-1600.jpg?s=t 120w, /concentrate/images/Features/Issue_624/willie-johnson-lynwood-powell-01-1600.jpg?s=l 265w, /concentrate/images/Features/Issue_624/willie-johnson-lynwood-powell-01-1600.jpg?s=lf 500w, /concentrate/images/Features/Issue_624/willie-johnson-lynwood-powell-01-1600.jpg?s=f 750w, /concentrate/images/Features/Issue_624/willie-johnson-lynwood-powell-01-1600.jpg?s=m 980w, /concentrate/images/Features/Issue_624/willie-johnson-lynwood-powell-01-1600.jpg?s=p 1125w, /concentrate/images/Features/Issue_624/willie-johnson-lynwood-powell-01-1600.jpg?s=mx 1600w"
      src="/concentrate/images/Features/Issue_624/willie-johnson-lynwood-powell-01-1600.jpg"
     />
 </noscript>
</div>
<div class="captionOverlay"><div class="captionText">Bad Credit is Childish co-owners Willie Johnson and Lynwood Powell. <span class='image-credits'>Doug Coombe</span></div></div>
</div>
</div>
<div class="carousel-cell">
<div class=" cell-item">
<div class="carousel-image-container">
<img class="carousel-image " alt="Willie Johnson." sizes="(min-width:1200px) 1600px, (min-width:1080px) 1125px, (min-width:850px) 980px, (min-width:571px) 750px, (min-width:400px) 500px, (min-width:200px) 265px, 265px" data-flickity-lazyload-srcset="/concentrate/images/Features/Issue_624/willie-johnson-01-1600.jpg?s=t 120w, /concentrate/images/Features/Issue_624/willie-johnson-01-1600.jpg?s=l 265w, /concentrate/images/Features/Issue_624/willie-johnson-01-1600.jpg?s=lf 500w, /concentrate/images/Features/Issue_624/willie-johnson-01-1600.jpg?s=f 750w, /concentrate/images/Features/Issue_624/willie-johnson-01-1600.jpg?s=m 980w, /concentrate/images/Features/Issue_624/willie-johnson-01-1600.jpg?s=p 1125w, /concentrate/images/Features/Issue_624/willie-johnson-01-1600.jpg?s=mx 1600w" data-flickity-lazyload-src="/concentrate/images/Features/Issue_624/willie-johnson-01-1600.jpg" />
<noscript>
 <img class="carousel-image "
      alt="Willie Johnson."
      sizes="(min-width:1200px) 1600px, (min-width:1080px) 1125px, (min-width:850px) 980px, (min-width:571px) 750px, (min-width:400px) 500px, (min-width:200px) 265px, 265px"
      srcset="/concentrate/images/Features/Issue_624/willie-johnson-01-1600.jpg?s=t 120w, /concentrate/images/Features/Issue_624/willie-johnson-01-1600.jpg?s=l 265w, /concentrate/images/Features/Issue_624/willie-johnson-01-1600.jpg?s=lf 500w, /concentrate/images/Features/Issue_624/willie-johnson-01-1600.jpg?s=f 750w, /concentrate/images/Features/Issue_624/willie-johnson-01-1600.jpg?s=m 980w, /concentrate/images/Features/Issue_624/willie-johnson-01-1600.jpg?s=p 1125w, /concentrate/images/Features/Issue_624/willie-johnson-01-1600.jpg?s=mx 1600w"
      src="/concentrate/images/Features/Issue_624/willie-johnson-01-1600.jpg"
     />
 </noscript>
</div>
<div class="captionOverlay"><div class="captionText">Willie Johnson. <span class='image-credits'>Doug Coombe</span></div></div>
</div>
</div>
<div class="carousel-cell">
<div class=" cell-item">
<div class="carousel-image-container">
<img class="carousel-image " alt="Lynwood Powell." sizes="(min-width:1200px) 1600px, (min-width:1080px) 1125px, (min-width:850px) 980px, (min-width:571px) 750px, (min-width:400px) 500px, (min-width:200px) 265px, 265px" data-flickity-lazyload-srcset="/concentrate/images/Features/Issue_624/lynwood-powell-01-1600.jpg?s=t 120w, /concentrate/images/Features/Issue_624/lynwood-powell-01-1600.jpg?s=l 265w, /concentrate/images/Features/Issue_624/lynwood-powell-01-1600.jpg?s=lf 500w, /concentrate/images/Features/Issue_624/lynwood-powell-01-1600.jpg?s=f 750w, /concentrate/images/Features/Issue_624/lynwood-powell-01-1600.jpg?s=m 980w, /concentrate/images/Features/Issue_624/lynwood-powell-01-1600.jpg?s=p 1125w, /concentrate/images/Features/Issue_624/lynwood-powell-01-1600.jpg?s=mx 1600w" data-flickity-lazyload-src="/concentrate/images/Features/Issue_624/lynwood-powell-01-1600.jpg" />
<noscript>
 <img class="carousel-image "
      alt="Lynwood Powell."
      sizes="(min-width:1200px) 1600px, (min-width:1080px) 1125px, (min-width:850px) 980px, (min-width:571px) 750px, (min-width:400px) 500px, (min-width:200px) 265px, 265px"
      srcset="/concentrate/images/Features/Issue_624/lynwood-powell-01-1600.jpg?s=t 120w, /concentrate/images/Features/Issue_624/lynwood-powell-01-1600.jpg?s=l 265w, /concentrate/images/Features/Issue_624/lynwood-powell-01-1600.jpg?s=lf 500w, /concentrate/images/Features/Issue_624/lynwood-powell-01-1600.jpg?s=f 750w, /concentrate/images/Features/Issue_624/lynwood-powell-01-1600.jpg?s=m 980w, /concentrate/images/Features/Issue_624/lynwood-powell-01-1600.jpg?s=p 1125w, /concentrate/images/Features/Issue_624/lynwood-powell-01-1600.jpg?s=mx 1600w"
      src="/concentrate/images/Features/Issue_624/lynwood-powell-01-1600.jpg"
     />
 </noscript>
</div>
<div class="captionOverlay"><div class="captionText">Lynwood Powell. <span class='image-credits'>Doug Coombe</span></div></div>
</div>
</div>
</div>
<div class="carousel carousel-thumbs" data-flickity='{ "asNavFor": "#ctl00_ContentPlaceHolder1_ctl05 .carousel-main", "cellAlign":"center", "contain": true, "autoPlay": false, "fullscreen": false, "fade": false, "adaptiveHeight": true, "imagesLoaded": true, "lazyLoad": true, "cellSelector": ".carousel-cell", "setGallerySize": false, "prevNextButtons": false, "pageDots": false }'>
<div class="carousel-cell">
<img class="carousel-image lazy-load " data-src="/concentrate/images/Features/Issue_624/willie-johnson-lynwood-powell-01-1600.jpg?s=l" alt="Thumbnail image" />
<noscript>
 <img class="carousel-image "
      src="/concentrate/images/Features/Issue_624/willie-johnson-lynwood-powell-01-1600.jpg?s=l"
      alt="Thumbnail image"
     />
 </noscript>
</div>
<div class="carousel-cell">
<img class="carousel-image lazy-load " data-src="/concentrate/images/Features/Issue_624/willie-johnson-01-1600.jpg?s=l" alt="Thumbnail image" />
<noscript>
 <img class="carousel-image "
      src="/concentrate/images/Features/Issue_624/willie-johnson-01-1600.jpg?s=l"
      alt="Thumbnail image"
     />
 </noscript>
</div>
<div class="carousel-cell">
<img class="carousel-image lazy-load " data-src="/concentrate/images/Features/Issue_624/lynwood-powell-01-1600.jpg?s=l" alt="Thumbnail image" />
<noscript>
 <img class="carousel-image "
      src="/concentrate/images/Features/Issue_624/lynwood-powell-01-1600.jpg?s=l"
      alt="Thumbnail image"
     />
 </noscript>
</div>
</div>
<div class="clear"></div>
</div>
</div>
<div class="body">
Ypsilanti residents and entrepreneurs Willie Johnson and Lynwood Powell want to help young people avoid some of the financial pitfalls they experienced as young adults.<br>
<br>
&#34;When I first got to college, I was handed credit cards left and right. I was thinking it&#39;s free money,&#34; Johnson says. He and Powell are co-owners of <a href="https://badcreditischildish.com/"><span>Bad Credit Is Childish</span></a>, an umbrella credit repair company whose services include Time Travel Credit Repair for adults and BCIC Academy for young people. BCIC Academy is an online platform designed to teach teenagers about financial literacy topics.<br>
<br>
&#34;As a parent, you want to make sure your own child doesn&#39;t make the same mistake,&#34; Johnson says. &#34;Why are we still okay with kids going to college, getting credit cards, and graduating already in debt? They can&#39;t obtain a house or any place to stay because they were never taught how to build credit.&#34;<br>
<br>
Before starting Bad Credit Is Childish, Powell worked for local schools as a paraprofessional and later as a social worker. He says he is passionate about education and empowering his community.<br>
<br>
&#34;I was in foster care when I was younger, and my social worker was the one who uplifted and empowered me to navigate difficulties in life,&#34; Powell says. &#34;So when I became a social worker, I had that in mind. Someone assisted me, and I wanted to always give back in that manner.&#34;<br>
<span class="content-image-inline content-image-full content-image-no-border"><noscript><img src="https://www.secondwavemedia.com/concentrate/images/Features/Issue_624/lynwood-powell-02-1600.jpg" srcset="https://www.secondwavemedia.com/concentrate/images/Features/Issue_624/lynwood-powell-02-1600.jpg?s=l 265w, https://www.secondwavemedia.com/concentrate/images/Features/Issue_624/lynwood-powell-02-1600.jpg?s=lf 500w, https://www.secondwavemedia.com/concentrate/images/Features/Issue_624/lynwood-powell-02-1600.jpg?s=f 750w" sizes="(min-width:550px) 750px, (min-width:300px) 500px, 265px"></noscript><img data-src="https://www.secondwavemedia.com/concentrate/images/Features/Issue_624/lynwood-powell-02-1600.jpg" class="lazy-load" data-srcset="https://www.secondwavemedia.com/concentrate/images/Features/Issue_624/lynwood-powell-02-1600.jpg?s=l 265w, https://www.secondwavemedia.com/concentrate/images/Features/Issue_624/lynwood-powell-02-1600.jpg?s=lf 500w, https://www.secondwavemedia.com/concentrate/images/Features/Issue_624/lynwood-powell-02-1600.jpg?s=f 750w" data-sizes="(min-width:550px) 750px, (min-width:300px) 500px, 265px"><span class="content-image-text">Lynwood Powell.</span></span><br>
He sees his credit repair company and BCIC Academy&#39;s virtual financial literacy courses as a way to empower the children he used to work with, along with their parents.<br>
<br>
&#34;If only parents knew how powerful building credit is,&#34; Powell says. &#34;It&#39;s not something that&#39;s taught to us in high school or college. I wanted to peel back that layer and let individuals know that you can achieve those goals, like home ownership or owning a car or business or just being financially free.&#34;<br>
<br>
Powell says people lose a lot of money from ignorance.<br>
<br>
&#34;If you don&#39;t know, you pay more,&#34; Powell says.<br>
<br>
Powell and Johnson have known each other since they were young adults working at the same factory together. They both thought they had potential to do more with their lives, but they were stymied by a lack of knowledge about money and finances.&nbsp;<br>
<br>
They started comparing notes and sharing their victories as they tried to improve their credit scores. Johnson was pleased when he was able to get a $2,400 medical bill completely wiped off his wife&#39;s credit report, for instance.<br>
<span class="content-image-inline content-image-full content-image-no-border"><noscript><img src="https://www.secondwavemedia.com/concentrate/images/Features/Issue_624/willie-johnson-02-1600.jpg" srcset="https://www.secondwavemedia.com/concentrate/images/Features/Issue_624/willie-johnson-02-1600.jpg?s=l 265w, https://www.secondwavemedia.com/concentrate/images/Features/Issue_624/willie-johnson-02-1600.jpg?s=lf 500w, https://www.secondwavemedia.com/concentrate/images/Features/Issue_624/willie-johnson-02-1600.jpg?s=f 750w" sizes="(min-width:550px) 750px, (min-width:300px) 500px, 265px"></noscript><img data-src="https://www.secondwavemedia.com/concentrate/images/Features/Issue_624/willie-johnson-02-1600.jpg" class="lazy-load" data-srcset="https://www.secondwavemedia.com/concentrate/images/Features/Issue_624/willie-johnson-02-1600.jpg?s=l 265w, https://www.secondwavemedia.com/concentrate/images/Features/Issue_624/willie-johnson-02-1600.jpg?s=lf 500w, https://www.secondwavemedia.com/concentrate/images/Features/Issue_624/willie-johnson-02-1600.jpg?s=f 750w" data-sizes="(min-width:550px) 750px, (min-width:300px) 500px, 265px"><span class="content-image-text">Willie Johnson.</span></span><br>
&#34;At that point, we knew we had a service to provide, because the things we were doing were really working,&#34; Johnson says.<br>
<br>
Shortly after that, the two established Time Travel Credit Repair at 301 W. Michigan Ave. in downtown Ypsilanti and began attracting clients through word of mouth.<br>
<br>
They both found gratification in helping adults raise their credit scores and achieve their goals. Johnson says helping someone buy a car or a house can be &#34;life-changing&#34; for that person.<br>
<br>
Rhonda Douglas took advantage of Johnson and Powell&#39;s credit repair services when she moved for a job. She says her credit &#34;wasn&#39;t terrible&#34; but she wanted to make sure there were no issues if she needed to buy new appliances, for instance.<br>
<br>
&#34;By the time I settled and introduced myself at my new job, I was in the saddle and my credit was on the upswing,&#34; Douglas says.&nbsp;<br>
<br>
A few years after launching their business, Johnson and Powell came up with the catchphrase &#34;Bad Credit Is Childish,&#34; and changed the branding for their business to match. And in 2021, the pair decided to launch BCIC Academy.<br>
<span class="content-image-inline content-image-full content-image-no-border"><noscript><img src="https://www.secondwavemedia.com/concentrate/images/Features/Issue_624/lnwood-powell-willie-johnson-02-1600.jpg" srcset="https://www.secondwavemedia.com/concentrate/images/Features/Issue_624/lnwood-powell-willie-johnson-02-1600.jpg?s=l 265w, https://www.secondwavemedia.com/concentrate/images/Features/Issue_624/lnwood-powell-willie-johnson-02-1600.jpg?s=lf 500w, https://www.secondwavemedia.com/concentrate/images/Features/Issue_624/lnwood-powell-willie-johnson-02-1600.jpg?s=f 750w" sizes="(min-width:550px) 750px, (min-width:300px) 500px, 265px"></noscript><img data-src="https://www.secondwavemedia.com/concentrate/images/Features/Issue_624/lnwood-powell-willie-johnson-02-1600.jpg" class="lazy-load" data-srcset="https://www.secondwavemedia.com/concentrate/images/Features/Issue_624/lnwood-powell-willie-johnson-02-1600.jpg?s=l 265w, https://www.secondwavemedia.com/concentrate/images/Features/Issue_624/lnwood-powell-willie-johnson-02-1600.jpg?s=lf 500w, https://www.secondwavemedia.com/concentrate/images/Features/Issue_624/lnwood-powell-willie-johnson-02-1600.jpg?s=f 750w" data-sizes="(min-width:550px) 750px, (min-width:300px) 500px, 265px"><span class="content-image-text">Bad Credit is Childish co-owners Lynwood Powell and Willie Johnson.</span></span><br>
&#34;We include a lot of things in the academy that are really important, like the credit scoring system, monitoring your credit, and identity theft,&#34; Johnson says.<br>
<br>
They began by touring Cass Technical High School and Ypsilanti High School, as well as a Boys and Girls Club, to get the message out about their online platform for teaching youth about financial literacy. Individuals can pay to take the course themselves, but Powell and Johnson want to offer the course at a reduced rate for schools to use.<br>
<br>
&#34;We&#39;ve already been contacted by schools about including us into their summer school or even their school curriculum,&#34; Johnson says.&nbsp;<br>
<br>
Taryn Willis, logistics coordinator for BCIC, says the Upward Bound program at Eastern Michigan University has discussed bringing BCIC Academy into that program. The BCIC Academy team has also connected with students at a new media course at the University of Michigan, with the potential for those students to come on as BCIC interns.<br>
<br>
Bringing on former NFL star <a href="https://www.secondwavemedia.com/concentrate/innovationnews/michaelvick0619.aspx"><span>Michael Vick as a brand ambassador</span></a> has also helped spread the word, not just here in Michigan, but in Vick&#39;s home state of Virginia and other locations around the United States where Vick has a following, Johnson says.<br>
<br>
Willis says Powell and Johnson don&#39;t keep their trade secrets to themselves, but share them with their whole team.&nbsp;<br>
<span class="content-image-inline content-image-full content-image-no-border"><noscript><img src="https://www.secondwavemedia.com/concentrate/images/Features/Issue_624/taryn-willis-02-1600.jpg" srcset="https://www.secondwavemedia.com/concentrate/images/Features/Issue_624/taryn-willis-02-1600.jpg?s=l 265w, https://www.secondwavemedia.com/concentrate/images/Features/Issue_624/taryn-willis-02-1600.jpg?s=lf 500w, https://www.secondwavemedia.com/concentrate/images/Features/Issue_624/taryn-willis-02-1600.jpg?s=f 750w" sizes="(min-width:550px) 750px, (min-width:300px) 500px, 265px"></noscript><img data-src="https://www.secondwavemedia.com/concentrate/images/Features/Issue_624/taryn-willis-02-1600.jpg" class="lazy-load" data-srcset="https://www.secondwavemedia.com/concentrate/images/Features/Issue_624/taryn-willis-02-1600.jpg?s=l 265w, https://www.secondwavemedia.com/concentrate/images/Features/Issue_624/taryn-willis-02-1600.jpg?s=lf 500w, https://www.secondwavemedia.com/concentrate/images/Features/Issue_624/taryn-willis-02-1600.jpg?s=f 750w" data-sizes="(min-width:550px) 750px, (min-width:300px) 500px, 265px"><span class="content-image-text">Taryn Willis.</span></span><br>
&#34;They empower people on the team, also, to learn about their own credit and do things to fix it,&#34; Willis says. &#34;It&#39;s exciting to learn the same things they&#39;re teaching the masses.&#34;<br>
<br>
The team also shares their victories, like in a recent meeting where one employee mentioned her credit score had improved by several dozen points.<br>
<br>
Johnson and Powell will continue to do credit repair with adults, but they are especially excited about kicking off the academy and helping young people establish and maintain good financial habits.<br>
<br>
&#34;We want to empower kids at an early age so they won&#39;t make the same mistakes we made, and they&#39;ll have a bright future,&#34; Powell says.<br>
<br>
The first session of the BCIC Academy kicks off in February. More information is available <a href="https://badcreditischildish.com"><span>here</span></a>.<br>
<br>
<strong>Sarah Rigg is a freelance writer and editor in Ypsilanti Township and the project manager of</strong><a href="https://www.secondwavemedia.com/concentrate/tags/taghome.aspx?tag=On+the+Ground"> <strong>On the Ground Ypsilanti</strong></a><strong>. She joined</strong><a href="https://www.secondwavemedia.com/concentrate/default.aspx"> <strong>Concentrate</strong></a><strong> as a news writer in early 2017 and is an occasional contributor to other</strong><a href="http://www.issuemediagroup.com/"> <strong>Issue Media Group</strong></a><strong> publications. You may reach her at </strong><a href="mailto:sarahrigg1@gmail.com"><strong>sarahrigg1@gmail.com</strong></a><strong>.</strong><br>
<br>
<strong>All photos by </strong><a href="http://www.dougcoombe.com/"><strong>Doug Coombe</strong></a><strong>.</strong>
</div>
<div class="clear"></div>
<div class="contentMeta">
<div class="share">
<span class="shareText">Share</span>
<span class="buttons">
<a class="shareFacebook" target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3a%2f%2fwww.secondwavemedia.com%2fconcentrate%2ffeatures%2fbcicacademy0624.aspx" onclick="ga('send','social','facebook','send','/concentrate/features/bcicacademy0624.aspx');ga('subsite.send','social','facebook','send','/features/bcicacademy0624.aspx');"><img src="/images/share_facebook.png" alt="Share on Facebook" /></a>
<a class="shareTwitter" target="_blank" href="https://twitter.com/share?url=https%3a%2f%2fwww.secondwavemedia.com%2fconcentrate%2ffeatures%2fbcicacademy0624.aspx&amp;text=Ypsi-based+credit+repair+company+launches+financial+literacy+academy+for+youth" onclick="ga('send','social','twitter','send','/concentrate/features/bcicacademy0624.aspx');ga('subsite.send','social','twitter','send','/features/bcicacademy0624.aspx');"><img src="/images/share_twitter.png" alt="Share on Twitter" /></a>
<a class="shareLinkedin" target="_blank" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https%3a%2f%2fwww.secondwavemedia.com%2fconcentrate%2ffeatures%2fbcicacademy0624.aspx&amp;title=Ypsi-based+credit+repair+company+launches+financial+literacy+academy+for+youth" onclick="ga('send','social','linkedin','send','/concentrate/features/bcicacademy0624.aspx');ga('subsite.send','social','linkedin','send','/features/bcicacademy0624.aspx');"><img src="/images/share_linkedin.png" alt="Share on LinkedIn" /></a>
<a class="shareMailto" href="mailto:?Body=https%3a%2f%2fwww.secondwavemedia.com%2fconcentrate%2ffeatures%2fbcicacademy0624.aspx&amp;Subject=Share:Ypsi-based+credit+repair+company+launches+financial+literacy+academy+for+youth" onclick="ga('send','social','email','send','/concentrate/features/bcicacademy0624.aspx');ga('subsite.send','social','email','send','/features/bcicacademy0624.aspx');"><img src="/images/share_email.png" alt="Share through Email" /></a></span>
<script>
        </script>
</div>
<div class="toolBar">
<div class="toolBarLike">
<div id="fb-like" class="fb-like" data-href="https://www.secondwavemedia.com/concentrate/features/bcicacademy0624.aspx" data-width="" data-layout="button_count" data-action="like" data-size="small" data-share="false"></div>
<script>facebookComponents.register('fb-like');</script>
</div>
</div>
</div>
<div class="authorSection">
<div class="clear"></div>
</div>
<div class="contentMeta">
<div class="relatedContent">
<h4>Related Tags</h4>
<div class="tags separator">
<a title="View more stories related to Business" href="/concentrate/tags/taghome.aspx?tag=Business">Business</a>, <a title="View more stories related to Business Development" href="/concentrate/tags/taghome.aspx?tag=Business+Development">Business Development</a>, <a title="View more stories related to Education" href="/concentrate/tags/taghome.aspx?tag=Education">Education</a>, <a title="View more stories related to Entrepreneurship" href="/concentrate/tags/taghome.aspx?tag=Entrepreneurship">Entrepreneurship</a>, <a title="View more stories related to Finance" href="/concentrate/tags/taghome.aspx?tag=Finance">Finance</a>, <a title="View more stories related to Kids and Education" href="/concentrate/tags/taghome.aspx?tag=Kids+and+Education">Kids and Education</a>, <a title="View more stories related to On the Ground" href="/concentrate/tags/taghome.aspx?tag=On+the+Ground">On the Ground</a>&nbsp;
</div>
</div>
</div>
<div id="commentsContainer" class="commentsContainer">
<a name="comments"></a>
<div id="fb-comments" class="fb-comments" data-href="https://www.concentratemedia.com/features/bcicacademy0624.aspx" data-width="560" data-numposts="100"></div>
<script>
facebookComponents.register('fb-comments');
</script>
</div>
</div>
</div>
<div class="col-xs-12 col-md-2 hidden-xs hidden-sm"></div>
</div>
<div class="row">
<div class="col-xs-12 hidden-xs hidden-sm">
<div class="columnList network horizontal">
<h3>
Across Our Network
</h3>
<div class="clearfix">
<div>
<ul class="textWrapList noBullets">
<li>
<div class="listImage thumb">
<a href="https://www.highgroundnews.com/features/walk-down-broad-avenue-new-spots-treasured-favorites.aspx" target="_blank">
<noscript><img src="https://www.highgroundnews.com/galleries/broad-ave-sugar-ghost-ice-cream-front.jpg?s=l" class="thumb"></noscript>
<img data-src="https://www.highgroundnews.com/galleries/broad-ave-sugar-ghost-ice-cream-front.jpg?s=l" class="lazy-load thumb">
</a></div>
<a href="https://www.highgroundnews.com/features/walk-down-broad-avenue-new-spots-treasured-favorites.aspx" target="_blank">A walk down Broad Avenue: new spots, treasured favorites</a>
<div id="ctl00_ContentPlaceHolder1_ctl11_RepeaterColumns_ctl01_Div1" class="additionalattribute">
Source: High Ground
</div>
<div class="clear"></div>
</li>
<li>
<div class="listImage thumb">
<a href="https://www.flintside.com/inthenews/100k-ideas-receives-consumers-energy-foundation-grant.aspx" target="_blank">
<noscript><img src="https://www.flintside.com/galleries/100kideas.png?s=l" class="thumb"></noscript>
<img data-src="https://www.flintside.com/galleries/100kideas.png?s=l" class="lazy-load thumb">
</a></div>
<a href="https://www.flintside.com/inthenews/100k-ideas-receives-consumers-energy-foundation-grant.aspx" target="_blank">100K Ideas receives $35,000 grant from The Consumers Energy Foundation</a>
<div id="ctl00_ContentPlaceHolder1_ctl11_RepeaterColumns_ctl02_Div1" class="additionalattribute">
Source: Flintside
</div>
<div class="clear"></div>
</li>
<li>
<div class="listImage thumb">
<a href="https://www.modeldmedia.com/features/block-by-block-dave-merritt-straight-gate-renaissance-of-hope.aspx" target="_blank">
<noscript><img src="https://www.modeldmedia.com/FilterD/images/merrit2.jpg?s=l" class="thumb"></noscript>
<img data-src="https://www.modeldmedia.com/FilterD/images/merrit2.jpg?s=l" class="lazy-load thumb">
</a></div>
<a href="https://www.modeldmedia.com/features/block-by-block-dave-merritt-straight-gate-renaissance-of-hope.aspx" target="_blank">A former UM basketball star is on a mission to help redevelop this West Side Detroit neighborhood</a>
<div id="ctl00_ContentPlaceHolder1_ctl11_RepeaterColumns_ctl03_Div1" class="additionalattribute">
Source: Model D
</div>
<div class="clear"></div>
</li>
<li>
<div class="listImage thumb">
<a href="https://www.secondwavemedia.com/concentrate/features/BlackHistoryMobile.aspx" target="_blank">
<noscript><img src="https://www.secondwavemedia.com/concentrate/images/Features/flo_0309.jpg?s=l" class="thumb"></noscript>
<img data-src="https://www.secondwavemedia.com/concentrate/images/Features/flo_0309.jpg?s=l" class="lazy-load thumb">
</a></div>
<a href="https://www.secondwavemedia.com/concentrate/features/BlackHistoryMobile.aspx" target="_blank">Mobile museum sees Black history on the move in Howell</a>
<div id="ctl00_ContentPlaceHolder1_ctl11_RepeaterColumns_ctl04_Div1" class="additionalattribute">
Source: Concentrate
</div>
<div class="clear"></div>
</li>
</ul>
</div>
</div>
<div class="sponsor clearfix">
<div class="sponsortext">Sponsored By:</div>

<div class="adzone " id="ctl00_ContentPlaceHolder1_ctl11_AdZone1">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Sponsor: Network');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=77b3a6ba0bb04b7e8db4f76e4124418b&amp;cb=69626319719' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=17&amp;zoneid=9171&amp;cb=69626319719&amp;n=77b3a6ba0bb04b7e8db4f76e4124418b&amp;Page=17~%2fconcentrate%2ffeatures%2fbcicacademy0624.aspx&amp;Tag=17%7eEducation%2c17%7eKids+and+Education%2c17%7eEntrepreneurship%2c17%7eBusiness%2c17%7eFinance%2c17%7eBusiness+Development%2c17%7eOn+the+Ground%2c17%7e90143965-fbb0-416e-99c1-0d9d9b6d89ea%2c17%7eadf53f38-0853-4720-8d1e-b83c46f811bd%2c17%7e3dbf1eb1-ef0f-4e02-b246-05e4b88a2d05%2c17%7eb1e096bb-097d-4688-94ed-279a7fb76c11' border='0' alt='' /></a></noscript>
</div>
</div>
<div class="clear"></div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="container-fluid contentSection2 no-padding">
<div class="container-fluid container-inner no-padding">
</div>
</div>
<div class="container-fluid footerAdsSection no-padding">
<div class="container-fluid container-inner no-padding">
<div class="container">
<div class="byline">Sponsored By</div>
<div id="footeradholder">
<div id="row" class="row">
<div class="col-xs-6 col-sm-4 col-md-2 footerad">

<div class="adzone " id="ctl00_Footer1_AdZone1">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Footer 01');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=8ca89d8547c5423cb17ed62ad45308b9&amp;cb=69626319719' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=17&amp;zoneid=1701&amp;cb=69626319719&amp;n=8ca89d8547c5423cb17ed62ad45308b9&amp;Page=17~%2fconcentrate%2ffeatures%2fbcicacademy0624.aspx&amp;Tag=17%7eEducation%2c17%7eKids+and+Education%2c17%7eEntrepreneurship%2c17%7eBusiness%2c17%7eFinance%2c17%7eBusiness+Development%2c17%7eOn+the+Ground%2c17%7e90143965-fbb0-416e-99c1-0d9d9b6d89ea%2c17%7eadf53f38-0853-4720-8d1e-b83c46f811bd%2c17%7e3dbf1eb1-ef0f-4e02-b246-05e4b88a2d05%2c17%7eb1e096bb-097d-4688-94ed-279a7fb76c11' border='0' alt='' /></a></noscript>
</div>
</div>
<div class="col-xs-6 col-sm-4 col-md-2 footerad">

<div class="adzone " id="ctl00_Footer1_AdZone2">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Footer 02');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=9e1248e9257d4c6a8f1f4ab3f818ef3f&amp;cb=69626319719' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=17&amp;zoneid=1702&amp;cb=69626319719&amp;n=9e1248e9257d4c6a8f1f4ab3f818ef3f&amp;Page=17~%2fconcentrate%2ffeatures%2fbcicacademy0624.aspx&amp;Tag=17%7eEducation%2c17%7eKids+and+Education%2c17%7eEntrepreneurship%2c17%7eBusiness%2c17%7eFinance%2c17%7eBusiness+Development%2c17%7eOn+the+Ground%2c17%7e90143965-fbb0-416e-99c1-0d9d9b6d89ea%2c17%7eadf53f38-0853-4720-8d1e-b83c46f811bd%2c17%7e3dbf1eb1-ef0f-4e02-b246-05e4b88a2d05%2c17%7eb1e096bb-097d-4688-94ed-279a7fb76c11' border='0' alt='' /></a></noscript>
</div>
</div>
<div class="col-xs-6 col-sm-4 col-md-2 footerad">

<div class="adzone " id="ctl00_Footer1_AdZone3">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Footer 03');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=212619a6238f4af28ab0ccfa0db617ae&amp;cb=69626319719' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=17&amp;zoneid=1703&amp;cb=69626319719&amp;n=212619a6238f4af28ab0ccfa0db617ae&amp;Page=17~%2fconcentrate%2ffeatures%2fbcicacademy0624.aspx&amp;Tag=17%7eEducation%2c17%7eKids+and+Education%2c17%7eEntrepreneurship%2c17%7eBusiness%2c17%7eFinance%2c17%7eBusiness+Development%2c17%7eOn+the+Ground%2c17%7e90143965-fbb0-416e-99c1-0d9d9b6d89ea%2c17%7eadf53f38-0853-4720-8d1e-b83c46f811bd%2c17%7e3dbf1eb1-ef0f-4e02-b246-05e4b88a2d05%2c17%7eb1e096bb-097d-4688-94ed-279a7fb76c11' border='0' alt='' /></a></noscript>
</div>
</div>
<div class="col-xs-6 col-sm-4 col-md-2 footerad">

<div class="adzone " id="ctl00_Footer1_AdZone4">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Footer 04');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=33cae675500640bab149d7eebd70c70c&amp;cb=69626319719' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=17&amp;zoneid=1704&amp;cb=69626319719&amp;n=33cae675500640bab149d7eebd70c70c&amp;Page=17~%2fconcentrate%2ffeatures%2fbcicacademy0624.aspx&amp;Tag=17%7eEducation%2c17%7eKids+and+Education%2c17%7eEntrepreneurship%2c17%7eBusiness%2c17%7eFinance%2c17%7eBusiness+Development%2c17%7eOn+the+Ground%2c17%7e90143965-fbb0-416e-99c1-0d9d9b6d89ea%2c17%7eadf53f38-0853-4720-8d1e-b83c46f811bd%2c17%7e3dbf1eb1-ef0f-4e02-b246-05e4b88a2d05%2c17%7eb1e096bb-097d-4688-94ed-279a7fb76c11' border='0' alt='' /></a></noscript>
</div>
</div>
<div class="col-xs-6 col-sm-4 col-md-2 footerad">

<div class="adzone " id="ctl00_Footer1_AdZone5">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Footer 05');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=ec32fb2d8314420bbbd761a05405067e&amp;cb=69626319719' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=17&amp;zoneid=1705&amp;cb=69626319719&amp;n=ec32fb2d8314420bbbd761a05405067e&amp;Page=17~%2fconcentrate%2ffeatures%2fbcicacademy0624.aspx&amp;Tag=17%7eEducation%2c17%7eKids+and+Education%2c17%7eEntrepreneurship%2c17%7eBusiness%2c17%7eFinance%2c17%7eBusiness+Development%2c17%7eOn+the+Ground%2c17%7e90143965-fbb0-416e-99c1-0d9d9b6d89ea%2c17%7eadf53f38-0853-4720-8d1e-b83c46f811bd%2c17%7e3dbf1eb1-ef0f-4e02-b246-05e4b88a2d05%2c17%7eb1e096bb-097d-4688-94ed-279a7fb76c11' border='0' alt='' /></a></noscript>
</div>
</div>
<div class="col-xs-6 col-sm-4 col-md-2 footerad">

<div class="adzone " id="ctl00_Footer1_AdZone6">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Footer 06');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=24c7b9a76dda47bb80ceec19475968ab&amp;cb=69626319719' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=17&amp;zoneid=1706&amp;cb=69626319719&amp;n=24c7b9a76dda47bb80ceec19475968ab&amp;Page=17~%2fconcentrate%2ffeatures%2fbcicacademy0624.aspx&amp;Tag=17%7eEducation%2c17%7eKids+and+Education%2c17%7eEntrepreneurship%2c17%7eBusiness%2c17%7eFinance%2c17%7eBusiness+Development%2c17%7eOn+the+Ground%2c17%7e90143965-fbb0-416e-99c1-0d9d9b6d89ea%2c17%7eadf53f38-0853-4720-8d1e-b83c46f811bd%2c17%7e3dbf1eb1-ef0f-4e02-b246-05e4b88a2d05%2c17%7eb1e096bb-097d-4688-94ed-279a7fb76c11' border='0' alt='' /></a></noscript>
</div>
</div>
</div>
<div id="row" class="row">
<div class="col-xs-6 col-sm-4 col-md-2 footerad">

<div class="adzone " id="ctl00_Footer1_AdZone7">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Footer 07');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=f7eb329179484a5b81fa27fe68830bf2&amp;cb=69626319719' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=17&amp;zoneid=1707&amp;cb=69626319719&amp;n=f7eb329179484a5b81fa27fe68830bf2&amp;Page=17~%2fconcentrate%2ffeatures%2fbcicacademy0624.aspx&amp;Tag=17%7eEducation%2c17%7eKids+and+Education%2c17%7eEntrepreneurship%2c17%7eBusiness%2c17%7eFinance%2c17%7eBusiness+Development%2c17%7eOn+the+Ground%2c17%7e90143965-fbb0-416e-99c1-0d9d9b6d89ea%2c17%7eadf53f38-0853-4720-8d1e-b83c46f811bd%2c17%7e3dbf1eb1-ef0f-4e02-b246-05e4b88a2d05%2c17%7eb1e096bb-097d-4688-94ed-279a7fb76c11' border='0' alt='' /></a></noscript>
</div>
</div>
<div class="col-xs-6 col-sm-4 col-md-2 footerad">

<div class="adzone " id="ctl00_Footer1_AdZone8">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Footer 08');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=d4a0fad38d4e4ddc9c9f4daa450e4f62&amp;cb=69626319719' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=17&amp;zoneid=1708&amp;cb=69626319719&amp;n=d4a0fad38d4e4ddc9c9f4daa450e4f62&amp;Page=17~%2fconcentrate%2ffeatures%2fbcicacademy0624.aspx&amp;Tag=17%7eEducation%2c17%7eKids+and+Education%2c17%7eEntrepreneurship%2c17%7eBusiness%2c17%7eFinance%2c17%7eBusiness+Development%2c17%7eOn+the+Ground%2c17%7e90143965-fbb0-416e-99c1-0d9d9b6d89ea%2c17%7eadf53f38-0853-4720-8d1e-b83c46f811bd%2c17%7e3dbf1eb1-ef0f-4e02-b246-05e4b88a2d05%2c17%7eb1e096bb-097d-4688-94ed-279a7fb76c11' border='0' alt='' /></a></noscript>
</div>
</div>
<div class="col-xs-6 col-sm-4 col-md-2 footerad">

<div class="adzone " id="ctl00_Footer1_AdZone9">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Footer 09');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=25fe60208dc94b1fb896df15bf5f9033&amp;cb=69626319719' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=17&amp;zoneid=1709&amp;cb=69626319719&amp;n=25fe60208dc94b1fb896df15bf5f9033&amp;Page=17~%2fconcentrate%2ffeatures%2fbcicacademy0624.aspx&amp;Tag=17%7eEducation%2c17%7eKids+and+Education%2c17%7eEntrepreneurship%2c17%7eBusiness%2c17%7eFinance%2c17%7eBusiness+Development%2c17%7eOn+the+Ground%2c17%7e90143965-fbb0-416e-99c1-0d9d9b6d89ea%2c17%7eadf53f38-0853-4720-8d1e-b83c46f811bd%2c17%7e3dbf1eb1-ef0f-4e02-b246-05e4b88a2d05%2c17%7eb1e096bb-097d-4688-94ed-279a7fb76c11' border='0' alt='' /></a></noscript>
</div>
</div>
<div class="col-xs-6 col-sm-4 col-md-2 footerad">

<div class="adzone " id="ctl00_Footer1_AdZone10">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Footer 10');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=7dd89cb1916045f5b8716d1931c0de28&amp;cb=69626319719' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=17&amp;zoneid=1710&amp;cb=69626319719&amp;n=7dd89cb1916045f5b8716d1931c0de28&amp;Page=17~%2fconcentrate%2ffeatures%2fbcicacademy0624.aspx&amp;Tag=17%7eEducation%2c17%7eKids+and+Education%2c17%7eEntrepreneurship%2c17%7eBusiness%2c17%7eFinance%2c17%7eBusiness+Development%2c17%7eOn+the+Ground%2c17%7e90143965-fbb0-416e-99c1-0d9d9b6d89ea%2c17%7eadf53f38-0853-4720-8d1e-b83c46f811bd%2c17%7e3dbf1eb1-ef0f-4e02-b246-05e4b88a2d05%2c17%7eb1e096bb-097d-4688-94ed-279a7fb76c11' border='0' alt='' /></a></noscript>
</div>
</div>
<div class="col-xs-6 col-sm-4 col-md-2 footerad">

<div class="adzone " id="ctl00_Footer1_AdZone11">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Footer 11');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=ae6dd418e38e4a8186a2dfc0bf05598a&amp;cb=69626319719' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=17&amp;zoneid=1711&amp;cb=69626319719&amp;n=ae6dd418e38e4a8186a2dfc0bf05598a&amp;Page=17~%2fconcentrate%2ffeatures%2fbcicacademy0624.aspx&amp;Tag=17%7eEducation%2c17%7eKids+and+Education%2c17%7eEntrepreneurship%2c17%7eBusiness%2c17%7eFinance%2c17%7eBusiness+Development%2c17%7eOn+the+Ground%2c17%7e90143965-fbb0-416e-99c1-0d9d9b6d89ea%2c17%7eadf53f38-0853-4720-8d1e-b83c46f811bd%2c17%7e3dbf1eb1-ef0f-4e02-b246-05e4b88a2d05%2c17%7eb1e096bb-097d-4688-94ed-279a7fb76c11' border='0' alt='' /></a></noscript>
</div>
</div>
<div class="col-xs-6 col-sm-4 col-md-2 footerad">

<div class="adzone " id="ctl00_Footer1_AdZone12">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Footer 12');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=29fa6db04ca447bda2372fb17c593cb5&amp;cb=69626319719' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=17&amp;zoneid=1712&amp;cb=69626319719&amp;n=29fa6db04ca447bda2372fb17c593cb5&amp;Page=17~%2fconcentrate%2ffeatures%2fbcicacademy0624.aspx&amp;Tag=17%7eEducation%2c17%7eKids+and+Education%2c17%7eEntrepreneurship%2c17%7eBusiness%2c17%7eFinance%2c17%7eBusiness+Development%2c17%7eOn+the+Ground%2c17%7e90143965-fbb0-416e-99c1-0d9d9b6d89ea%2c17%7eadf53f38-0853-4720-8d1e-b83c46f811bd%2c17%7e3dbf1eb1-ef0f-4e02-b246-05e4b88a2d05%2c17%7eb1e096bb-097d-4688-94ed-279a7fb76c11' border='0' alt='' /></a></noscript>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="container-fluid footerSection no-padding">
<div class="container-fluid container-inner no-padding">
<div class="container">
<div class="row">
<div class="col-sm-6 col-md-3 footer-regions">
Regions
<ul><li><a class="site-second-wave" href='/'>Second Wave - Michigan</a></li><li><a class="site-capital-gains" href='/capitalgains/'>Capital Gains - Lansing</a></li><li><a class="site-midland" href='/midland/'>Catalyst Midland</a></li><li><a class="site-concentrate" href='/concentrate/'>Concentrate - Ann Arbor/Ypsi</a></li><li><a class="site-epicenter" href='/epicenter/'>Epicenter - Mount Pleasant</a></li><li><a class="site-route-bay-city" href='/baycity/'>Route Bay City</a></li><li><a class="site-southwest-michigan" href='/southwest-michigan/'>Southwest Michigan</a></li><li><a class="site-upper-peninsula" href='/upper-peninsula/'>Upper Peninsula</a></li><li><a class="site-the-keel" href='/the-keel/'>The Keel - Port Huron</a></li><li><a class="site-the-lakeshore" href='/lakeshore/'>The Lakeshore</a></li><li><a class="site-metromode" href='/metromode/'>Metromode - Metro Detroit</a></li></ul>
</div>
<div class="col-sm-6 col-md-3 footer-focus-areas">
Focus Areas
<ul><li><a href='/concentrate/focus/art-and-culture.aspx'>Arts and Culture</a></li><li><a href='/concentrate/focus/community-development.aspx'>Community Development</a></li><li><a href='/concentrate/focus/diversity.aspx'>Diversity</a></li><li><a href='/concentrate/focus/economic-development.aspx'>Economic Development</a></li><li><a href='/concentrate/focus/entrepreneurship.aspx'>Entrepreneurship</a></li><li><a href='/concentrate/focus/equity.aspx'>Equity</a></li><li><a href='/concentrate/focus/healthy-communities.aspx'>Healthy Communities</a></li><li><a href='/concentrate/focus/kids-and-education.aspx'>Kids and Education</a></li><li><a href='/concentrate/focus/sustainability.aspx'>Sustainability</a></li><li><a href='/concentrate/focus/technology-and-innovation.aspx'>Technology and Innovation</a></li><li><a href='/concentrate/focus/transportation.aspx'>Transportation</a></li></ul>
</div>
<div class="col-sm-6 col-md-3 footer-links">
<ul>
<li><a href="/concentrate/about/about.aspx">About Concentrate</a></li>
<li><a href="/concentrate/about/contactus.aspx">Contact Us</a></li>
<li><a href="/concentrate/about/tips.aspx">Have a tip for us?</a></li>
<li><a href="/concentrate/about/privacypolicy.aspx">Privacy Policy</a></li>
<li><a href="/concentrate/about/submitleadjobs.aspx">Submit a Lead</a></li>
<li><a href="/concentrate/about/termsofuse.aspx">Terms of Use</a></li>
</ul>
</div>
</div>
<div class="row">
<div class="col-md-12">Copyright &copy; Issue Media Group. All rights reserved.</div>
</div>
</div>
</div>
</div>
</div>
<script>
var pageInfo = {"article":true,"post_id":"f64b34f8-5633-4028-9df9-f72720ad3c13","post_type":"Long Featured Story","taxonomies":{"tags":["Business","Business Development","Education","Entrepreneurship","Finance","Kids and Education","On the Ground"]},"url":"https://www.secondwavemedia.com/concentrate/features/bcicacademy0624.aspx"};
if (window.pico) {
    window.pico('visit', pageInfo);
}
</script>
<div>
<input type="hidden" name="__VIEWSTATEGENERATOR" id="__VIEWSTATEGENERATOR" value="148FB807" />
</div></form>
<script src="https://cdnjs.cloudflare.com/ajax/libs/flickity/2.2.1/flickity.pkgd.min.js" integrity="sha256-3Maq7M1TC8sOke8B4gRkhfGtETqGWq+xenQO7k2mHjI=" crossorigin="anonymous"></script>
<script src="https://unpkg.com/flickity-fullscreen@1.1.1/fullscreen.js"></script>
<script src="https://cdnjs.cloudflare.com/ajax/libs/vanilla-lazyload/17.3.0/lazyload.min.js"></script>
<script>
var lazyLoadInstance = new LazyLoad({
    elements_selector: ".lazy-load",
    callback_loaded: lazyloadCallback
});
</script>
</body>
</html>
